Home > PHP, Zend Framework > Zend Framework 1.0.0 RC1 && Zend_Db_Statement

Zend Framework 1.0.0 RC1 && Zend_Db_Statement

Zainteresowała mnie dziś nowa wersja Zend Framework 1.0.0RC1 – i to był błąd. Ktoś wpadł na pomysł przepisania klasy Zend_DB_Statement, stworzono nową klasę: Zend_Db_Statement_Pdo i z nią właśnie jest problem. Jednak nie do końca z nią a bardziej z PDO. Wcześniej klasa Statement implementowała metodę bindParam jako wyrażenie regularne podmieniające stringi – o dziwo, to mi działało. Nowa implementacja bindParam deleguje metodę do obiektu PDO. Tymczasem ta metoda klasa PDO (w moim PHP 5.2.1) nie działa: SQLSTATE[HY093]: Invalid parameter number: no parameters were bound. Wniosek, na razie będę dalej korzystam z starej wersji biblioteki.
Categories: PHP, Zend Framework Tags:
  1. No comments yet.
  1. No trackbacks yet.

Subscribe without commenting